Fusion16 - Debian/Ubuntu - No usable GPU devices found [Solved with issues]

Moderator: Chad

User avatar
magdesign
Posts: 20
Joined: Sun Mar 26, 2017 12:36 pm
Been thanked: 2 times
Contact:

Fusion16 - Debian/Ubuntu - No usable GPU devices found [Solved with issues]

#1

Post by magdesign » Thu Sep 12, 2019 10:51 am

Fusion version:

FusionStudio 16 and Fusion Studio 16.1 beta9 build 9

OS and version:

Ubuntu/Pop!_OS 18.04 LTS 18.04.
(Also tested with 16.04 LTS)

Additional relevant system info:

Nvidia GeForce RTX 2080Ti 11GB, Nvidia 435 opensource driver, Cuda V10.1.105
(Also tested with Cuda V7.x and various other Nvidia drivers, 418, 430, opensource and proprietary)

Description of the bug:
When starting Fusion Studio 16, in Fusion console I get following error:

FusionCore library not found
Warning: No usable GPU devices found.

Severity (Trivial, Minor, Major, Critical)
Minor problem (support will not help, they stick to CentOS).
Without GPU support the software is much slower.
Fusion 9.0.2 build 15 runs perfectly with GPU support on the same machine.

Maybe its a missing symlink to the FusionCore Library, no idea where this is located since a search does not show a location.
I checked with:

Code: Select all

ldd '/opt/BlackmagicDesign/Fusion16/Fusion'

and then search all the librarys with "locate" if it is on the system, nothing missing...

Update:
On another computer with a Nvidia GTX 1060,
Fusion16 is running with GPU support, but only when using the 390 driver.

Steps to reproduce:
Install Fusion 16 on a Debian/Ubuntu System with a newer Nvidia driver, e.g. 418, 430, 435 and start it, open the Fusion console and see the error.

(Also tried installing with danieltufvesson script, did not help.)

Please, if possible, provide a Fusion setup to help demonstrate the behavior, either as an attachment or between [code] tags:


User avatar
magdesign
Posts: 20
Joined: Sun Mar 26, 2017 12:36 pm
Been thanked: 2 times
Contact:

Re: Fusion16 - Debian/Ubuntu - No usable GPU devices found [Solved with issues]

#2

Post by magdesign » Mon Sep 16, 2019 5:23 am

Updated to the newest beta version:16.1 beta 11 build 11

Now the GPU gets recognized,
but Fusion16 is 30% slower in rendering then Fusion9 on the exact same machine. :(


User avatar
SirEdric
Fusionator
Posts: 2065
Joined: Tue Aug 05, 2014 10:04 am
Answers: 4
Real name: Eric Westphal
Been thanked: 162 times
Contact:

Re: Fusion16 - Debian/Ubuntu - No usable GPU devices found [Solved with issues]

#3

Post by SirEdric » Mon Sep 16, 2019 9:39 am

magdesign wrote:
Mon Sep 16, 2019 5:23 am

but Fusion16 is 30% slower in rendering then Fusion9 on the exact same machine.

<nag> Probably it consumes too much GPU power for the new fancy interface </nag>


User avatar
magdesign
Posts: 20
Joined: Sun Mar 26, 2017 12:36 pm
Been thanked: 2 times
Contact:

Re: Fusion16 - Debian/Ubuntu - No usable GPU devices found [Solved with issues]

#4

Post by magdesign » Mon Sep 23, 2019 8:06 am

:lol:

lol..

User avatar
magdesign
Posts: 20
Joined: Sun Mar 26, 2017 12:36 pm
Been thanked: 2 times
Contact:

Re: Fusion16 - Debian/Ubuntu - No usable GPU devices found [Solved with issues]

#5

Post by magdesign » Tue Nov 19, 2019 2:51 am

Its so frustrating.
With Fusion Studio 16.1.1 there is again "No usable GPU devices found"

Other software like for example Blender get much faster, better UI, and more stable in every new release ( current release speeds up rendering by factor 2!!).
Blackmagic fixes no bugs, destroys the UI, gets much slower and unstable in every release, its a shame that they went for cheap-ware.
I'd rather prefer paying 1k-2k for a stable and usable software.

Really looking forward to Cavalry Animation software, since Nuke is to expensive and Fusion 9 gets in its years with the years....

What an industry is this? :P

User avatar
SecondMan
Site Admin
Posts: 3787
Joined: Thu Jul 31, 2014 5:31 pm
Answers: 8
Location: Vancouver, Canada
Been thanked: 147 times
Contact:

Re: Fusion16 - Debian/Ubuntu - No usable GPU devices found [Solved with issues]

#6

Post by SecondMan » Fri Nov 22, 2019 6:43 am

Is the recurring issue exactly the same as in the opening post, including steps to reproduce?

Will unmark this topic as [FIXED] if it is.

User avatar
Rhys Alu
Posts: 5
Joined: Sat Jan 05, 2019 7:04 pm

Re: Fusion16 - Debian/Ubuntu - No usable GPU devices found [Solved with issues]

#7

Post by Rhys Alu » Sun Nov 24, 2019 4:58 pm

Also getting the same problem in Debian Bullseye. Have latest NVIDIA and CUDA drivers.

Same error in console:
"FusionCore library not found
Warning: No usable GPU devices found."

and I can't select CUDA in GPU API settings.

Running 16.1 Build 18

Possibly Build 19 fixes these issues? Unfortunately danieltufvesson.com/ hasn't made a .deb compiler for it yet.

Also of note, CUDA is selected and working in DaVinci Resolve.

User avatar
magdesign
Posts: 20
Joined: Sun Mar 26, 2017 12:36 pm
Been thanked: 2 times
Contact:

Re: Fusion16 - Debian/Ubuntu - No usable GPU devices found [Solved with issues]

#8

Post by magdesign » Thu Dec 05, 2019 2:46 pm

The issue still persists!


But as a workaround I completely switched to Natron and Blender.
The render speeds are amazing and both of them also support Debian, so I stopped loosing nerves with BMD, their support is catastrophic and their releases as well....

User avatar
SecondMan
Site Admin
Posts: 3787
Joined: Thu Jul 31, 2014 5:31 pm
Answers: 8
Location: Vancouver, Canada
Been thanked: 147 times
Contact:

Re: Fusion16 - Debian/Ubuntu - No usable GPU devices found [Solved with issues]

#9

Post by SecondMan » Fri Dec 06, 2019 12:17 am

That's the spirit!