Welcome to WSL!

Make yourself at home, but before posting, please may I ask you to read the following topics.


Posting 101
Server space, screenshots, and you

Thank you!

PS. please pretty please:


Image

Getting started with Reactor

Moderator: SecondMan

User avatar
SecondMan
Site Admin
Posts: 4456
Joined: Thu Jul 31, 2014 5:31 pm
Answers: 27
Location: Vancouver, Canada
Been thanked: 109 times
Contact:

Re: Getting started with Reactor

#136

Post by SecondMan » Tue Mar 31, 2020 1:23 pm

Ah yes, so you said - also your avatar is kinda telling.

Anything in the Console?

In the Reactor preferences, try setting Concurrent cURL Tranfers to 1.

At this point I'm just guessing. Never seen anything like it.

Tags:

User avatar
benbergman
Posts: 10
Joined: Mon Mar 30, 2020 7:47 pm

Re: Getting started with Reactor

#137

Post by benbergman » Tue Mar 31, 2020 2:24 pm

If you are referring to Workspace > Console, this is the contents after starting up Resolve and attempting a resync.

Code: Select all

[Resync Repository] Started


[Initial Reactor.cfg] /var/BlackmagicDesign/DaVinci Resolve/Fusion/Reactor/System/Reactor.cfg
table: 0x7fc515d197e8
	Repos = table: 0x7fc515d19830
		Reactor = table: 0x7fc515d199c8
			PrevCommitID = e12eaf27f955b6130473babfc5304dc5dcf2a48a
			Protocol = GitLab
			ID = 5058837
		_Core = table: 0x7fc515d198a0
			PrevCommitID = e12eaf27f955b6130473babfc5304dc5dcf2a48a
			Protocol = GitLab
			ID = 5058837
	Settings = table: 0x7fc515d19ae0
		Reactor = table: 0x7fc515d19b28
			ConcurrentTransfers = 1
			NewForDays = 7
			ViewLayout = Balanced View
			LiveSearch = true
			AskForInstallScriptPermissions = true
			MarkAsNew = true
			PrevSyncTime = 1585679599


[Reactor.cfg] Clearing PrevCommitID Entries
	[Reactor.PrevCommitID] e12eaf27f955b6130473babfc5304dc5dcf2a48a	
	[_Core.PrevCommitID] e12eaf27f955b6130473babfc5304dc5dcf2a48a	


[Edited Reactor.cfg] /var/BlackmagicDesign/DaVinci Resolve/Fusion/Reactor/System/Reactor.cfg
table: 0x7fc515d1a800
	Repos = table: 0x7fc515d1a848
		Reactor = table: 0x7fc515d1a948
			ID = 5058837
			Protocol = GitLab
		_Core = table: 0x7fc515d1a890
			ID = 5058837
			Protocol = GitLab
	Settings = table: 0x7fc515d1aa00
		Reactor = table: 0x7fc515d1aa48
			LiveSearch = true
			NewForDays = 7
			ViewLayout = Balanced View
			MarkAsNew = true
			AskForInstallScriptPermissions = true
			ConcurrentTransfers = 1
			PrevSyncTime = 1585679599


[Reactor] Opening Reactor Window
[Done]
Reducing to one curl command at a time did not fix the issue.

User avatar
SecondMan
Site Admin
Posts: 4456
Joined: Thu Jul 31, 2014 5:31 pm
Answers: 27
Location: Vancouver, Canada
Been thanked: 109 times
Contact:

Re: Getting started with Reactor

#138

Post by SecondMan » Tue Mar 31, 2020 2:44 pm

Next try :)

In your Reactor.cfg, remove the lines that say PrevCommitID. Then start Reactor again.

User avatar
benbergman
Posts: 10
Joined: Mon Mar 30, 2020 7:47 pm

Re: Getting started with Reactor

#139

Post by benbergman » Tue Mar 31, 2020 3:08 pm

I closed Resolve, removed the two PrevCommitID lines from /var/BlackmagicDesign/DaVinci Resolve/Fusion/Reactor/System/Reactor.cfg, then started Resolve back up again. Opening Reactor, I still do not see Suck Less Audio. Doing a resync at this point still does not fix it.

Somehow I always manage to get the head scratcher problems. :)

User avatar
SecondMan
Site Admin
Posts: 4456
Joined: Thu Jul 31, 2014 5:31 pm
Answers: 27
Location: Vancouver, Canada
Been thanked: 109 times
Contact:

Re: Getting started with Reactor

#140

Post by SecondMan » Tue Mar 31, 2020 4:16 pm

When you removed the two lines and restarted Reactor, did you see Reactor updating all the atoms before starting up? Also a bunch of core files including .png ones. Should have taken a lot longer to start up.

User avatar
benbergman
Posts: 10
Joined: Mon Mar 30, 2020 7:47 pm

Re: Getting started with Reactor

#141

Post by benbergman » Tue Mar 31, 2020 7:52 pm

Yes, I did see a bunch of core things, atoms, and pngs. It did seem to take a bit longer.

User avatar
SecondMan
Site Admin
Posts: 4456
Joined: Thu Jul 31, 2014 5:31 pm
Answers: 27
Location: Vancouver, Canada
Been thanked: 109 times
Contact:

Re: Getting started with Reactor

#142

Post by SecondMan » Tue Mar 31, 2020 8:47 pm

Well, last thing to do for now then; please may you read the debug variable manual, set those and post any console messages and Reactor log here?

Thanks

User avatar
benbergman
Posts: 10
Joined: Mon Mar 30, 2020 7:47 pm

Re: Getting started with Reactor

#143

Post by benbergman » Tue Mar 31, 2020 9:11 pm

After setting debug variables, rebooting, launching Reactor, and then doing a resync:

console output:

Code: Select all

[Reactor Log] /tmp/Reactor/ReactorLog.txt

[Resync Repository] Started


[Initial Reactor.cfg] /var/BlackmagicDesign/DaVinci Resolve/Fusion/Reactor/System/Reactor.cfg
table: 0x7f7197bb7788
	Repos = table: 0x7f7197bb77d0
		Reactor = table: 0x7f7197bf0928
			PrevCommitID = 01259400e01fc5e1045fc8a509714375ef03b926
			Protocol = GitLab
			ID = 5058837
		_Core = table: 0x7f7197bb7c70
			PrevCommitID = 01259400e01fc5e1045fc8a509714375ef03b926
			Protocol = GitLab
			ID = 5058837
	Settings = table: 0x7f7197bf0970
		Reactor = table: 0x7f7197b99d88
			MarkAsNew = true
			NewForDays = 7
			ViewLayout = Balanced View
			ConcurrentTransfers = 1
			AskForInstallScriptPermissions = true
			LiveSearch = true
			PrevSyncTime = 1585713769


[Reactor.cfg] Clearing PrevCommitID Entries
	[Reactor.PrevCommitID] 01259400e01fc5e1045fc8a509714375ef03b926	
	[_Core.PrevCommitID] 01259400e01fc5e1045fc8a509714375ef03b926	


[Edited Reactor.cfg] /var/BlackmagicDesign/DaVinci Resolve/Fusion/Reactor/System/Reactor.cfg
table: 0x7f7197bd2468
	Repos = table: 0x7f7197bd24b0
		Reactor = table: 0x7f7197bd2340
			ID = 5058837
			Protocol = GitLab
		_Core = table: 0x7f7197bd22c0
			ID = 5058837
			Protocol = GitLab
	Settings = table: 0x7f7197bd21c8
		Reactor = table: 0x7f7197bd2210
			ConcurrentTransfers = 1
			NewForDays = 7
			ViewLayout = Balanced View
			LiveSearch = true
			AskForInstallScriptPermissions = true
			MarkAsNew = true
			PrevSyncTime = 1585713769


[Reactor] Opening Reactor Window
[Done]
[Reactor Log] /tmp/Reactor/ReactorLog.txt

Reactor log:
ReactorLog.txt
(676.49 KiB) Downloaded 1 time

User avatar
benbergman
Posts: 10
Joined: Mon Mar 30, 2020 7:47 pm

Re: Getting started with Reactor

#144

Post by benbergman » Wed Apr 01, 2020 7:21 pm

Just to test things out I tried installing Reactor on a MacBook running macOS 10.14.6 instead of my main Arch Linux machine and I get the following error:

Code: Select all

[string "lj2curl/curl_ffi"]:1440: dlopen(libcurl.dylib, 5): image not found
I definitely have *a* libcurl.dylib at /usr/lib/, but I'm not sure where it is actually looking. I didn't see any mention of installing libcurl in the install instructions, but perhaps I missed something there.

User avatar
SecondMan
Site Admin
Posts: 4456
Joined: Thu Jul 31, 2014 5:31 pm
Answers: 27
Location: Vancouver, Canada
Been thanked: 109 times
Contact:

Re: Getting started with Reactor

#145

Post by SecondMan » Tue Apr 07, 2020 12:11 am

Good news (I think)!

After someone else posted what looks like the same issue, we found that GitLab subtly changed the syntax of the headers that Reactor uses to pull content. A fix has been pushed.

No need to reinstall or update. Just do another Repository Resync next time, and you should be good.

User avatar
benbergman
Posts: 10
Joined: Mon Mar 30, 2020 7:47 pm

Re: Getting started with Reactor

#146

Post by benbergman » Tue Apr 07, 2020 1:00 pm

Awesome, thanks for the fix!

FYI, I tried just doing a re-sync and that did not work, but reinstalling through the menu entry got it working.

User avatar
GuillemV
Posts: 3
Joined: Thu Sep 05, 2019 1:33 pm

Re: Getting started with Reactor

#147

Post by GuillemV » Sun Apr 19, 2020 12:07 pm

Hi, I'm getting the same message that holds the installing of Reactor:

[string "lj2curl/curl_ffi"]:1440: dlopen(libcurl.dylib, 5): image not found

I am trying to install it for the first time, so I can't try "reinstalling through the menu entry".
i'm in Resolve Stiudio 16.2 on OSX 10.14.6 if that's of any help

Can anyone give a hand to a newbie?
Thanks a lot!!

User avatar
SecondMan
Site Admin
Posts: 4456
Joined: Thu Jul 31, 2014 5:31 pm
Answers: 27
Location: Vancouver, Canada
Been thanked: 109 times
Contact:

Re: Getting started with Reactor

#148

Post by SecondMan » Sun Apr 19, 2020 1:16 pm

GuillemV wrote:
Sun Apr 19, 2020 12:07 pm
i'm in Resolve Stiudio 16.2 on OSX 10.14.6 if that's of any help
Yup, known issue, Reactor doesn't work in Fusion 16.2/Mac (however, it has recently been spotted to work with some security tweaks). Please contact BMD, let them know this is important for you: support@blackmagicdesign.com

User avatar
GuillemV
Posts: 3
Joined: Thu Sep 05, 2019 1:33 pm

Re: Getting started with Reactor

#149

Post by GuillemV » Mon Apr 20, 2020 2:30 am

Thanks SecondMan :))
I wrote support, fingers crossed...
I tried enabling full access for Fusion at the security Pane as reccomended by intelligent machine but it didn't work.

The thing is I can't access the scripts, i never managed to install Reactor so I can't do as you say:
"Next time you run Reactor, please re-sync the repository"

Should I downgrade to 16.1, install Reactor and then upgrade again?
I'm afraid of a downgrade, although 16.1.2 was indeed stable...

THANKS!!!

User avatar
SecondMan
Site Admin
Posts: 4456
Joined: Thu Jul 31, 2014 5:31 pm
Answers: 27
Location: Vancouver, Canada
Been thanked: 109 times
Contact:

Re: Getting started with Reactor

#150

Post by SecondMan » Mon Apr 20, 2020 10:13 pm

GuillemV wrote:
Mon Apr 20, 2020 2:30 am
Should I downgrade to 16.1, install Reactor and then upgrade again?
Perhaps not - try upgrading to 16.2.1 instead :)