Page 1 of 1

Reactor on Resolve installation failed

Posted: Wed Jun 12, 2019 3:27 pm
by samba2010
Hi everybody,

I'm trying to install Reactor 3 in Resolve 15 and it always crashes when the installer tries to restart the application.

I'm working on macOS Mojave 10.14.5. Not sure if there is something wrong about it.

The reactor version I'm trying to install is Version 3 - May 27, 2019

At the moment I'm not using other scripts. I'm very new at fusion and I'm still in the learning process.

Thank you so much in advance!

Re: Reactor on Resolve installation failed

Posted: Wed Jun 12, 2019 4:23 pm
by SecondMan
I don't know why it would crash Resolve, but the good news is that at the point of restarting, Reactor is already installed.

Check if it's not simply there and running swimmingly?

Image

Re: Reactor on Resolve installation failed

Posted: Thu Jun 13, 2019 1:22 am
by samba2010
Thanks for the answer! But nope, Reactor is not there :(
Screenshot 2019-06-13 at 10.17.54.png
Screenshot 2019-06-13 at 10.17.54.png (66.99 KiB) Viewed 879 times
By the way, in the workspace menu, I don't have any script sub-menu.

Any thoughts? Maybe a problem with the OS?

Thank you!

Re: Reactor on Resolve installation failed

Posted: Thu Jun 13, 2019 3:31 am
by Movalex
Did you try to install it for Resolve16? Reactor was updated to v3 recently, maybe a compatibility issue?

Re: Reactor on Resolve installation failed

Posted: Thu Jun 13, 2019 4:39 am
by samba2010
At the end, I ended up installing Resolve 16 and everything works like a charm :)

I'm thinking that maybe this is something related to the OS. I had reactor running in the same version of Resolve but, with a different OS (I can't remember which one but, it wasn't Mojave)

So, I think there's some kind of issue with Mojave. I've been experiencing a lot of issues with this new OS in Mac.

So, even if we couldn't find a logical answer to my problem, I hope this solution works for everybody.

Thank you so much for the quick replies! It is my first time posting and it was a great experience.

I used to work with Nuke but, must say, that I'm starting to fall in love with Resolve and Fusion :)

Re: Reactor on Resolve installation failed

Posted: Fri Jun 14, 2019 6:52 am
by SecondMan
Good you got it to work :)

I suspect reinstalling Resolve 15 may have solved your issue as well. The one thing that now comes to mind related to Mojave is that some of the permission levels changed in the OS (or something like it, I'm not a Mac user myself).

This results in Reactor not being able to recreate certain folders if for some reason they don't exist.

See this for more info and future reference: viewtopic.php?f=32&t=1775&p=13075#anchor-alldata

Partly this is where the custom install path functionality for Reactor 3 comes from...
samba2010 wrote:
Thu Jun 13, 2019 4:39 am
I used to work with Nuke but, must say, that I'm starting to fall in love with Resolve and Fusion :)
You're not the only one I'm sure :) - in any case you're in the right place to share the love! ;)