Page 1 of 1

[Update] CineForm Loader/Saver 1.5  [SUBMITTED]

Posted: Wed Feb 20, 2019 12:10 pm
by cinewrangler
Bugfixed version v1.5:

Linux
Windows
Mac

In v1.4 was a bug that caused a crash with YUV 4:2:2 files when the Loader's image format in Fusion was set to 32bit float.

Re: [Update] CineForm Loader/Saver 1.5

Posted: Wed Feb 20, 2019 3:32 pm
by SecondMan
And submitted, thanks! :cheer:

Re: [Update] CineForm Loader/Saver 1.5

Posted: Wed Apr 03, 2019 7:42 am
by RBemendo
Thanks for the update cinewrangler!!

I've confirmed all variants of Cineform from Adobe (10bit,12bit,12bit withAlpha(straight and preMultiplied), and 16bit float (with and without alpha, straight and premultiplied) all are working in CineForm Loader/Saver 1.5

Also, all variants created from Resolve 15.2 are all working in CineForm Loader/Saver 1.5

Unfortunately I have a few CineForm files that were created from older version of Adobe that are not being read. From the metadata I'm not able to tell anything that's different or out of the ordinary from the new files generated from both Adobe and Blackmagic.

Thanks again for tracking down the bugs!!

Re: [Update] CineForm Loader/Saver 1.5

Posted: Wed Apr 03, 2019 8:24 am
by cinewrangler
Thanks for the detailed testing you did!

Can you somehow share one of those files that don't work? - I've recently come across some QuickTime files that use 64bit file offsets (due to file being large) and don't have an 'ftyp' atom at the start. Those indeed fail to load. So could be that or something similar.