Archive Composition Script

User avatar
Mclawest
Fusioneer
Posts: 86
Joined: Tue Jul 28, 2015 6:31 am
Contact:

Re: Archive Composition Script

#46

Post by Mclawest » Wed Mar 21, 2018 7:39 am

what about "Include FileLUT"? ) would be nice...)

Tags:

Gene Cornelius
Posts: 29
Joined: Sun Mar 11, 2018 8:52 pm
Location: Haines, Alaska
Contact:

Re: Archive Composition Script

#47

Post by Gene Cornelius » Fri Mar 23, 2018 11:45 pm

Please forgive me ... this is not working at all (creates files, but does not link to them)

Kind of a basic function? What am I missing here? How to then share basic comps with media?

Strangely, even redirecting Loaders to source file (.psd) does not refresh. Seeing a lot of red.

Thanks!

User avatar
SirEdric
Fusionator
Posts: 1995
Joined: Tue Aug 05, 2014 10:04 am
Answers: 4
Real name: Eric Westphal
Been thanked: 146 times
Contact:

Re: Archive Composition Script

#48

Post by SirEdric » Sat Mar 24, 2018 1:16 am

Hmmm....works just fine for me (on almost a daily basis).

Where do you direct your archive folder to?
So if your comp lives in: X:\myComps\shot01\shot01.comp
do you set the archive to a subfolder of that?
(As in X:\myComps\shot01\Archive01\)?

Try directing it to a folder out of the original structure like
X:\myArchives\Archive01\

Does that change anything?

Gene Cornelius
Posts: 29
Joined: Sun Mar 11, 2018 8:52 pm
Location: Haines, Alaska
Contact:

Re: Archive Composition Script

#49

Post by Gene Cornelius » Sat Mar 24, 2018 12:18 pm

Glad to hear it actually does work reliably .. Thank you! I will be using it a lot! But until then:

Funny thing is that it would not let me redirect yesterday, ("no such file or directory" even though I just made one) so I let it go and copied the folders and comp copy to another directory manually. The files were there, as was the comp, but they would not read unless I manually linked.

I just did it again, this time (fresher coffee?) it let me redirect to a different location, but ... and here's where it gets interesting ... it copied the new comp copy, and made the folders for the .psd source files, but they were empty.

Mystery! I'll keep trying and report if I discover what I'm botching ...

Gene Cornelius
Posts: 29
Joined: Sun Mar 11, 2018 8:52 pm
Location: Haines, Alaska
Contact:

Re: Archive Composition Script

#50

Post by Gene Cornelius » Sat Mar 24, 2018 12:25 pm

OH ... one thing .. I just realized that I had secreted the original files into a temp folder to hide them when I was testing the redirected new files ... (faceplant) so that will solve the empty folders issue.

User avatar
SirEdric
Fusionator
Posts: 1995
Joined: Tue Aug 05, 2014 10:04 am
Answers: 4
Real name: Eric Westphal
Been thanked: 146 times
Contact:

Re: Archive Composition Script

#51

Post by SirEdric » Sat Mar 24, 2018 12:33 pm

Glad you solved it...:-)

Gene Cornelius
Posts: 29
Joined: Sun Mar 11, 2018 8:52 pm
Location: Haines, Alaska
Contact:

Re: Archive Composition Script

#52

Post by Gene Cornelius » Sat Mar 24, 2018 1:17 pm

Yes indeed ...

Aaaaaand: Success!

I am not sure why. I'm doing only one thing differently and it "shouldn't" make a difference - that is, I copied the new files (the comp copy and dependency folders) to a new directory (yes, I checked the time stamp). Somehow I either missed something in my fumblings or managed to corrupt something. At any rate, it works exactly as it should. And now I can copy and move the entire folder to my heart's content. Very cool!

As to the confusion of it not allowing me to redirect: That is due to thinking (silly me) that I could make a new folder and put the name of my comp (say, Beach V2 to keep track of versions) in a folder that I named. The mistake is that it only seems to work if I leave the name field blank (delete "Archive Composition") which makes some sense since it names the copied comp the same as the comp being archived, which helps assure versioning accuracy.

Cheers!