Getting tons of crashes when using Splines  [FIXED]

Moderator: Chad

User avatar
bowserlm
Fusionista
Posts: 334
Joined: Sat Apr 28, 2018 3:44 pm
Been thanked: 6 times

Getting tons of crashes when using Splines

#1

Post by bowserlm » Fri Feb 15, 2019 9:02 pm

Not sure what exactly is going on but I'm working on a comp and am using a lot of masks to combine plates. It's a crowd stitching shot.

Anyway, I'm getting constant instant crashes that are increasing with frequency sometimes when I create a mask, sometimes when I close a mask, sometimes when I move the points of a mask.

It's shaping up to be about every 5 minutes now at this point. Would love to have some kind of idea of what is going on with it.

Here's a crash log if it's helpful

https://www.dropbox.com/s/opzqqxf8iicls ... crash?dl=0

User avatar
SecondMan
Site Admin
Posts: 3577
Joined: Thu Jul 31, 2014 5:31 pm
Answers: 5
Location: Vancouver, Canada
Been thanked: 104 times
Contact:

Re: Getting tons of crashes when using Splines

#2

Post by SecondMan » Fri Feb 15, 2019 9:13 pm

Moving this to the Bug Tracker...

Assuming this is Fu Standalone?

If you could add a setup that reproduces the crashing, that's always helpful.

User avatar
bowserlm
Fusionista
Posts: 334
Joined: Sat Apr 28, 2018 3:44 pm
Been thanked: 6 times

Re: Getting tons of crashes when using Splines

#3

Post by bowserlm » Sat Feb 16, 2019 11:03 am

Here's a comp with 2 of the plates. They are on the bigger side but wanted to include in case that's part of the issue.

https://www.dropbox.com/sh/og3ptu3o1yiz ... 1AL7a?dl=0

Ultimately the shot is stitching 12 of these together.

I have to hit save literally after every click I make because this thing is crashing every other mask I manipulate.

And here's another crash log. Thing is crashing CONSTANTLY.

https://www.dropbox.com/s/q0ry2ze1c8i7m ... crash?dl=0

User avatar
intelligent machine
Fusionista
Posts: 427
Joined: Fri May 13, 2016 10:01 pm
Answers: 2
Location: Austin, Texas, USA
Been thanked: 32 times
Contact:

Re: Getting tons of crashes when using Splines

#4

Post by intelligent machine » Sat Feb 16, 2019 12:44 pm

According the the log this is also due to a memory allocation error.
I downloaded the files and played with mask points while the comp was playing through and caching. Did this for a little bit and no crashes or signs of struggle whatsoever.

Did you ever follow these tips someone posted here?
viewtopic.php?f=16&t=2767#p21596

My specs for comparison:
iMac Pro - 18 core Xeon, 128GB RAM, AMD Radeon Pro Vega 64

User avatar
bowserlm
Fusionista
Posts: 334
Joined: Sat Apr 28, 2018 3:44 pm
Been thanked: 6 times

Re: Getting tons of crashes when using Splines

#5

Post by bowserlm » Sat Feb 16, 2019 1:44 pm

Created a new user and installed only Fusion.

Opened up the comp and got a crash on creating the second mask, being in the comp for only like 20 seconds.

https://www.dropbox.com/s/e8x007cm2nr8f ... crash?dl=0

User avatar
intelligent machine
Fusionista
Posts: 427
Joined: Fri May 13, 2016 10:01 pm
Answers: 2
Location: Austin, Texas, USA
Been thanked: 32 times
Contact:

Re: Getting tons of crashes when using Splines

#6

Post by intelligent machine » Sat Feb 16, 2019 2:32 pm

Hmm... you can try disabling the OFX plugins and see if any of those are a culprit (RSMB, Sapphire, Neat Video). I don’t think this will solve it but worth a shot. Also, are you using the latest version of neat video?

User avatar
bowserlm
Fusionista
Posts: 334
Joined: Sat Apr 28, 2018 3:44 pm
Been thanked: 6 times

Re: Getting tons of crashes when using Splines

#7

Post by bowserlm » Sat Feb 16, 2019 2:35 pm

Neat Video is the only one being used.

Looks like I'm using version 4.8.0 and there is a 4.8.5.

*** Updated to 4.8.5 still getting the crashes.

User avatar
bowserlm
Fusionista
Posts: 334
Joined: Sat Apr 28, 2018 3:44 pm
Been thanked: 6 times

Re: Getting tons of crashes when using Splines

#8

Post by bowserlm » Sat Feb 16, 2019 4:37 pm

@intelligent machine BTW when testing that scene, it's not in playing down the scene or tweaking any parameters that I'm seeing the crashing.

It's in creating new masks predominantly. I get a crash about every 4th or 5th new mask I create. So about every 10 minutes. Incredibly frustrating.

So if testing that scene, try creating a bunch of masks and piping them in where the other ones are.

User avatar
Midgardsormr
Fusionator
Posts: 1213
Joined: Wed Nov 26, 2014 8:04 pm
Answers: 3
Location: Los Angeles, CA, USA
Been thanked: 94 times
Contact:

Re: Getting tons of crashes when using Splines

#9

Post by Midgardsormr » Sat Feb 16, 2019 5:32 pm

Do you get these crashes only with the BSpline, or also with Polygons?

User avatar
bowserlm
Fusionista
Posts: 334
Joined: Sat Apr 28, 2018 3:44 pm
Been thanked: 6 times

Re: Getting tons of crashes when using Splines

#10

Post by bowserlm » Sat Feb 16, 2019 5:43 pm

I was actually only using BSplines so I'm not sure about with the Polyline.

I don't think I've ever had any noticeable crashes with the other polygon shapes like circle and square.

User avatar
intelligent machine
Fusionista
Posts: 427
Joined: Fri May 13, 2016 10:01 pm
Answers: 2
Location: Austin, Texas, USA
Been thanked: 32 times
Contact:

Re: Getting tons of crashes when using Splines

#11

Post by intelligent machine » Sat Feb 16, 2019 6:15 pm

Okay. I can confirm the bug. I was using the polygon mask before but after adding additional B-spline masks Fusion did crash twice.

User avatar
intelligent machine
Fusionista
Posts: 427
Joined: Fri May 13, 2016 10:01 pm
Answers: 2
Location: Austin, Texas, USA
Been thanked: 32 times
Contact:

Re: Getting tons of crashes when using Splines

#12

Post by intelligent machine » Sat Feb 16, 2019 6:20 pm

I tried stacking a bunch of B-splines in a new comp with just a BG and no crash BUT this is what happens when I press play:

https://www.dropbox.com/s/ytgmvug400si5 ... M.mov?dl=0

User avatar
SirEdric
Fusionator
Posts: 1959
Joined: Tue Aug 05, 2014 10:04 am
Answers: 4
Real name: Eric Westphal
Been thanked: 135 times
Contact:

Re: Getting tons of crashes when using Splines

#13

Post by SirEdric » Sun Feb 17, 2019 1:10 am

A great philosopher once wrote: 'Naughty, naughty. Very naughty!'
Seems like a decent bug in the BSplines....:-(

User avatar
bowserlm
Fusionista
Posts: 334
Joined: Sat Apr 28, 2018 3:44 pm
Been thanked: 6 times

Re: Getting tons of crashes when using Splines

#14

Post by bowserlm » Sun Feb 17, 2019 1:11 am

Damn. I'm not a bezier fan at all.

User avatar
bowserlm
Fusionista
Posts: 334
Joined: Sat Apr 28, 2018 3:44 pm
Been thanked: 6 times

Re: Getting tons of crashes when using Splines

#15

Post by bowserlm » Mon Feb 18, 2019 12:19 pm

So it SEEMS like things are much more stable using Bezier splines than B-Splines. Hoping I'm not speaking too soon, but haven't had a crash yet with Bezier.

A bummer because I much prefer to mask with Bspline than Bezier.